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 About Importing and Exporting Designs
Translating CAD data between various systems can be difficult. Different CAD systems
have different representations of data. For instance, some systems contain the concept of
a hole and some do not. Differences in translation formats often cause data to be lost or
transformed.

 In Advanced Design System, translating physical designs is initiated from the layout
window using the File > Import and File > Export menu commands. The program's
import/export translators are highly configurable. Each translator has associated options
that you can set from the Import and Export dialog boxes. These options control how the
translator works. For example, with the IGES and GDSII format flatten option, a layout
can be translated as a flat, non-hierarchical design. Similarly, the merge option for these
formats creates two new polygons from two intersecting closed shapes.

Other options include arc conversions, treatment of holes and text, and in the layers file,
specification of layer translation tables. The IGES  translator has the greatest number of
options because IGES is such a broad standard. System defaults are included with the
product and are automatically used if no others are specified.

Translating schematic designs is initiated from the ADS Main or Schematic window using
the File > Import and File > Export menu commands. Similar to the Layout translators,
each schematic translator has associated options that control how the translator works.

 

 Layout Export Considerations
Before starting a layout, you should consider how the final output could affect the layout
process. Different output formats impose different  restrictions. The restrictions imposed
by GDSII are very different from those imposed by DXF, HPGL, Mask, or Gerber.

With all export formats, you must consider layout units and data base precision. The units
and precision used in layout should match those you want in the final output.

Usually no problems are associated with translating units that are in the same
measurement system (such as, mils to inches or centimeters to millimeters). However,
round-off errors can occur when translating from metric-to-English units or vice versa.

Similarly, no problem is associated with translating a less precise data base resolution in
the program to a more precise output resolution. However, the reverse process (such as,
0.001 Layout to 0.01 GDSII) can result in loss of data. 

  

 Available File Formats
The Import and Export commands enable you to import and export files in a variety of
different formats. You can import files through Advanced Design System's Main,
Schematic, or Layout window. All file export is currently done from the ADS Layout
window with the exception of Intermediate File Format (IFF) files. The following table
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shows the available file formats and the individual import/export options.

 

 Available Formats and Import/Export Options

Available File Formats and File Extensions ADS Main Window ADS Schematic
Window

ADS Layout

DXF/DWG (hierarchical) (.dxf, .dwg) - - Import/Export

DXF/DWG (flattened) (.dxf, .dwg) - - Import

EGS Archive Format (_a) - - Import/Export

EGS Generate Format (_g) - Import Import/Export

GDSII Stream Format (.gds) - - Import/Export

Gerber/Drill (.gbr) - - Import/Export

Gerber Viewer (.msk, .gbr) - - Import/Export

HPGL/2 (.hpg) - - Export

IFF (.iff) Import Import/Export Import/Export

IGES (.igs) - - Import/Export

Mask File (.msk) - Import Import/Export

MGC/PCB (.iff) Import - Import/Export

Cadence/PCB Import - Import/Export

ODB++ - - Import/Export

Netlist File † Import Import -

† For detailed information on SPICE (.cir, .cki) or Spectre (.scs) netlist file import, refer to the Netlist
Translator for SPICE and Spectre documentation.

Steps for importing and exporting these files are outlined in Importing and Exporting
Schematic and Layout Designs (trans).

  

 DXF/DWG

 The Drawing Exchange Format (DXF) was developed by Autodesk for its A utoCAD
product and is widely used to transfer geometric data between systems. Like the mask file
format, it provides a simple geometric representation of data. DXF files can be transferred
between PC-based or UNIX-based systems. DXF is a very simple file format that can be
read by most CAD programs that support DXF.

DWG is a binary format, therefore the files take less time to load and save. Advanced
Design System supports importing and exporting to/from AutoCAD. AutoCAD versions 12
to 2007 are supported for import. AutoCad versions 2000, 2004 and 2007 are supported
for export. Carefully consider how you want to use DXF/DWG output - including layer
numbering, use of holes, and polygon shapes - before beginning your layout design.
Setting up the proper layout rules in ADS can save a lot of time in generating acceptable
DXF/DWG output. For specific considerations or limitations, consult your AutoCAD
documentation. For details, see DXF/DWG Translator (trans).

  

 EGS (Archive/Generate)
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Engineering Graphics System (EGS) format is a general graphics format used for capturing
manually entered designs. EGS has been applied to ICs, Micro-circuits, Hybrids, and PC
Board design applications. Using this format, you can easily exchange data with other
programs using EGS formats.

The layout portion of Advanced Design System has adopted many of the primitive types
and styles that are part of the EGS standard, but has a more enriched set of capabilities
that structure information not representable in EGS. For example, EGS files cannot
represent embedded arcs.

Two variations of the EGS format are:

The Generate format is a flattened list of EGS primitives specified in the user-defined
unit space. No additional information is supplied such as supplied with the Archive
format.
The Archive format is a hierarchically organized list of EGS primitives specified in the
user-defined unit space. Information such as drawing shapes, layout units, database
precision, and grid spacing is included.

For details, see EGS Archive Files (trans) and EGS Generate Files (trans).

 

 GDSII Stream

 GDSII Stream Format (Calma) is an industry standard for translating final mask data to
foundries. The Advanced Design System reads GDSII versions 4.0 through 6.0 and writes
GDSII version 6.0.

Unlike other data formats, GDSII stream format is binary. You cannot easily view or edit a
stream format file using a text editor. This format is easily translated between different
CAD systems because it represents a highly restrictive data type. However, the format has
a number of significant limitations; these limitations are discussed in GDSII Stream File
Translator (trans).

 

 Gerber/Drill

 Gerber refers to various data input formats that Gerber Scientific uses to drive its
photoplotters. The Gerber format is used by photoplotters produced by other
manufacturers also. Advanced Design System supports various types of Gerber output via
mask files to either the Gerber or DXF translator. For details, see Gerber Translator
(trans).

 

 

 HPGL/2

HPGL/2 output is a subset of the HPGL/2 printer/plotter language. In Advanced Design
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System, you can export HPGL/2 files from the Layout window. For details, see HPGL/2
Files (trans).

 

 IFF 

The Intermediate File Format (IFF) is an ASCII file with a simple, line-oriented command
structure and a fairly rich set of constructs. This format is machine- and application-
independent, thus simplifying design data transfer.

IFF files are used as the exchange mechanism when transferring designs between
Advanced Design System and third-party EDA tools such as  Mentor Graphics Design
Architect and Cadence Analog Artist. For more information about these framework links,
contact your Agilent Technologies sales representative.

For details, see IFF Files (trans).

  

 IGES

 The Initial Graphics Exchange Specification (IGES) is an approved ANSI standard of the
U.S. Department of Commerce (ANSI Y14.25M) that is used extensively throughout the
computer-aided design and manufacturing world. The IGES format can represent both
mechanical and electrical design data in two and three dimensions.

Because IGES is such a broad standard, the government has attempted to further define a
stricter standard of IGES for the transfer of electrical design data.  This standard is known
as CALS specification. The CALS specification for IGES is officially contained in the military
specification MIL-D-28000, Digital Representation for Communication of Product Data:
IGES Application Subsets.

The Advanced Design System supports version 4.0 and 5.0 IGES formats. The program
reads and writes IGES CALS Level 1 (technical illustration) and Level 3
(electrical/electronic applications) files. Level 2 (engineering drawings) is not fully
supported since Level 2 is used primarily for drafting applications.

Even with the CALS standards, CAD systems accept very different IGES formats. Although
it is impossible to accommodate every format, you can use a number of options to
configure various IGES translators, including translators supplied by Autodesk, Mentor
Graphics, and Cadence. For details, see IGES Translator (trans).

 

 Mask File

 Mask file format is a simple flat (non-hierarchical) geometric description. The format
facilitates the transfer of simple geometric data for final mask processing. Only geometric
forms are described in a mask file; simulation data, element parameters, substrate
definitions, and hierarchy are not included.

The Gerber and DXF translators use the mask file format as an intermediate file when
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converting data to Gerber and DXF. For details, see Mask Files (trans).

 

 MGC/PCB

 MGC/PCB files are IFF files that are used exclusively for Mentor Graphics design transfers.  
Although this format is available from the Advanced Design System layout menu only, you
can transfer both schematic and layout information.
MGC/PCB files write to a specific location each and every time. When you select this
format, the filename and location of the IFF transport is determined automatically. For
details, MGC/PCB (trans).

 

 ODB++

ODB++ is widely accepted as a practical de-facto standard within the electronics industry
as an efficient way to move printed circuit bareboard, assembly and test data on the
manufacturing-engineering level within design/manufacturing supply chains. It is designed
as a simple yet comprehensive description of all entities needed in the manufacturing of a
printed circuit board. Advanced Design System supports importing and exporting to/from
ODB++ file. For details, see ODB++ Translator (trans)

 Netlist Files

Simulation Program with Integrated Circuit Emphasis ( SPICE) is a simulation tool used by
engineers throughout the world for simulating circuits of all types. Since its development
at the University of California Berkeley, SPICE has been commercialized and modified by a
large number of vendors and also adopted and modified by electronics companies for their
own in-house use. Many designers and companies have large investments in existing
subcircuits or device models described by SPICE netlists that they want to use with the
Advanced Design System from Agilent Technologies.

 Spectre is an EDA (Electronic Design Automation) tool produced by Cadence Design
Systems, Inc. Spectre is used by engineers throughout the world for simulating circuits of
all types. Many designers and companies have large investments in existing subcircuits or
device models described by Spectre netlists that they want to use with the Advanced
Design System (ADS) from Agilent Technologies.

For detailed information on SPICE or Spectre file import, refer to Netlist Translator for
SPICE and Spectre (netlist).
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 Importing and Exporting Schematic and
Layout Designs
This section provides information on importing and exporting schematic and layout files as
well as how to use the Advanced Design System Layer Editor. For information on
importing Netlists, refer to Importing a Netlist File (netlist).

Note
To prevent performance and memory consumption problems with large designs such as reticles or
imported designs for use with Momentum, refer to Disabling Layout Connectivity Features (usrguide).

  

 Importing a Schematic
For available file formats that you can import from an ADS Schematic window, refer to
Available Formats (trans). For information on importing SPICE and Spectre netlist files,
refer to the Netlist Translator for SPICE and Spectre (netlist).

The procedure for importing each format is generally the same, however the available
options differ. For options relating to a particular file format, see the appropriate section.

 To import a schematic design:

Open a schematic design in a workspace.1.
Click File > Import... from the schematic window. The Import dialog box appears.2.
Select the appropriate file format from the File Type drop-down list.3.
Click More Options to define options for the imported file. The More Options dialog4.
box appears.

Note
The program translators are controlled by translator options files. A system-wide options file exists
for each translator. These files can be found in the $HPEESOF_DIR/config directory. The default
system file is automatically read when you click More Options in the Import dialog box (unless a
local options file already exists in the current workspace directory). When you make changes in the
More Options dialog box and click OK, a local copy of the options file is written to the current
workspace directory.

Click Browse to specify the path and file name of the file you want to import.5.
Double-click as needed to locate the directory containing the schematic. By default,6.
all files are listed that have the file suffix appropriate for the chosen file format.
Select the schemaatic design you want to import and click OK. You are returned to7.
the Import dialog box and the selected filename appears in the field labeled Import
File Name (Source).
Where applicable, type a new name for your imported design in the New Design8.
Name (Destination) field.

Note
For certain file types, the translator uses the existing file name to determine the new design name.

Click OK to import the design and dismiss the Import dialog box.9.
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 Exporting a Schematic 
For available file formats that you can export from an ADS Schematic window, refer to
Available Formats (trans).

The procedure for exporting IFF files is the same as the import, but the available options
differ. For options relating to the IFF file format, see IFF Files (trans).

 To export a schematic design:

Open the schematic design and click File > Export. The Export dialog box appears.1.
Select IFF file format from the File Type drop-down list.2.
Click More Options to set export options. The More Options dialog box appears.3.
Change options as needed and click OK.4.
To specify a path for the exported file, click Browse.5.
Double-click as needed to locate the directory for the exported design. By default, all6.
files are listed that have the file suffix appropriate for the chosen file format.
Click OK.7.
Type a new filename in the Export dialog box, following the path, and click OK. The8.
file is written to the specified directory.

  

 Importing a Layout
For available file formats that you can import from an ADS Layout window, refer to
Available Formats and Import/Export Options (trans).

The procedure for importing each format is the same, but the available options differ. For
options relating to a particular file format, refer to the associated section.

To import a layout file:

In the ADS Layout window, click File > Import to open the Import dialog box.1.

In the File Type field, click the arrow in the right-hand corner to display a drop-down2.
list of available formats. Select the format you want to import.
Click More Options to define the options for your selected format.3.
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Note
Each format has its own set of import options. Refer to the individual translator topic.

In the More Options dialog box, click OK to save your settings and return to the4.
Import dialog box.
In the Import File Name (Source) field enter the full path of the source file.5.
Alternatively, click Browse to open the  Select Source File dialog box and locate the
file you want. After locating the file, click Open to accept the selection and return to
the Import dialog box. The appropriate suffix () is appended to the filename
automatically.

 In the New Design Name (Destination) field, enter the full destination path and a6.
name for the new file. Alternatively, you can click Browse to open the Select New
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Design Name dialog box and locate the destination path. After locating the file, click
Open to accept the selection and return to the Import dialog box. The appropriate
suffix is appended to the filter automatically.

Note
New Design Name (Destination) cannot be specified for EGS Archive Format, GDSII Stream Format,
IFF, Gerber, DXF, Mask, ODB__ or IGES files.

Click OK to accept the selections and start the import process. One or more files may7.
be created.

  

 Exporting a Layout
For available file formats that you can export from an ADS Layout window, refer to
Available Formats (trans).

The procedure for exporting each format is the same, but the available options differ. For
options relating to a particular file format, see the appropriate section.

Note
 Gerber Viewer appears as an export file option. It is not a file format, but is placed on the export file
menu so you can open the Gerber Viewer at any time.  In addition, you can access the Viewer during a
DXF or Gerber export (see Using the Gerber Viewer (trans)).

To export a layout file:

In the ADS Layout window, click File > Export. The Export dialog box appears.1.
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In the File type drop-down list to open the available formats. Select the format you2.
want to export.
Click More Options to define the options for the selected format.3.

Note
Each format has its own set of import options. Refer to the appropriate section.

In the More Options dialog box, click OK to save your settings and return to the4.
Export dialog box.
 In the Destination file, enter the full path of the destination file. Alternatively, click5.
Browse to open the Select Destination File dialog box. After locating the destination
directory, click OK to accept the selection and return to the Export dialog box. Enter
a file name. The appropriate suffix is appended to the file name automatically.
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Note
Destination file cannot be specified for MGC/PCB files.  MGC/PCB files are written to the same
predetermined location each and every time. For more information on this file type, see MGC/PCB
Files (trans).

Click OK to accept the selections and start the export process. Additional dialog6.
boxes display for the DXF, Gerber, IFF, and MGC/PCB formats. To complete
translation of these formats, refer to the appropriate section.
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 Using the Pre-Production Editor
ADS includes an editor that can display DXF/DWG and Gerber/Drill designs. Using the
editor, you can compare the DXF/DWG and Gerber/Drill files to the original ADS layout
design to verify that the design was exported correctly. Similarly, DXF/DWG files can be
previewed prior to import into ADS:

to edit a large design down to a smaller design prior to importing it into ADS. This
edited design can be saved and then imported in ADS.
or after import, to verify that the DXF/DWG design data and the ADS-imported
design appear similar.

 File Menu
The File menu contains common Open, Save, Save As, and Close functions and lists the
four most recent files viewed in the editor.

Note
When files are saved as Gerber/Drill files using the Pre-Production editor, the layer name is used as the
file name.

 Edit Menu
The Edit menu contains common and specialized editing commands.

 Enable Editing

Enables editing commands to be performed on the current design. De-select this item to
view the design in read-only mode. In this mode, editing commands are unavailable.
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 Undo

Undoes the last editing command. A stack of edit commands is created enabling you to
choose Undo repeatedly to return to an earlier state of your design. A stack is maintained
for each window, thus the Undo command works independently from window to window.

 Redo

Returns the file to the pre-undo state.

 Cut

Enables you to delete one or more items from one window, and paste in another window.

 Copy

Enables you to copy items in a given design window and then paste those items within the
same design window or another design window.

 Paste

Enables you to paste items that you previously cut or copied. You are prompted to enter
the X and Y coordinates of the position where you want to paste the copied items. Select
Apply to paste or Cancel to dismiss pasting.

 Delete

To delete selected items, click the Delete button on the toolbar, or press the Delete key
on the keyboard, or choose Delete from the Edit menu. Deleted items can be restored
using the Undo command.

 Select All

Enables you to select all figure(s).

 Deselect All

Deselects all the selected figure.

 Modify

This choice lets you modify the following items:

Select figures and click Union to perform union of the figures.
Select figures and click Intersection to perform union of the figures.
Select figures and click Union Minus Intersection to perform union of the figures
Select Crop to crop an area from a figure(s).
Select Chop to chop an area from a figure.
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Note
Union, Intersection, Union Minus Intersection, Crop, and Chop do not work for open ended figures with
zero width (for example arc and polylines).

 View Menu
The view menu contains commands that allow you to alter the view of the current design.

 View All

Your design is scaled and repositioned to fit within the viewing area.

 The Zoom Commands

The Zoom commands enable you to enlarge or shrink the area being viewed. You can
zoom in and zoom out using mouse wheel. The enlarged or condensed figure is moved
towards the center of the window.

Click Zoom To Area > click a point and then with the mouse button pressed move the
mouse to the bottom right of the area and release the mouse button to define a new view.

Click Zoom to Point to zoom in on a specified point in the window. Click to specify a point
and the current view is magnified by a factor of two, moving the point you specify to the
center of the window.

Click Zoom In By 2 to zoom in by a factor of 2.

Click Zoom Out By 2 to zoom out by a factor of 2.

 Measure

The Measure dialog allows you to measure lengths.

Absolute X, Y displays the absolute coordinates of the point of mouse click.
Delta X, Y gives the relative X and Y coordinates from previous mouse click.
Angle gives the angle with respect to a line horizontal to the X axis.
Cumulative distance gives the total length from starting point to current point.
Click Clear to reset the values for Absolute X,Y, Delta X, Y, Angle and Cumulative
distance.
Click Cancel to dismiss the measure dialog box.
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 Undo/Redo Stack

Shows last performed actions. You have an option to undo or redo the last operations
performed.

 Layer Table

The layer Table displays the layer information. It enables you to switch on/off layers from
display. It also enables you to view layer number, layer name and layer color. Click Select
All to view all the layers and Deselect All to switch off all the layers. All the layers are
displayed by default.

 Status

The status window displays messages about the status of the current design, as well as
warning and error messages.

 Window Menu
This menu contains the following common Window commands.

Click Close to close the active window.
Click Close All to close all open designs.
Click Tile to arrange all child windows in a tile pattern.
Click Cascade to arrange all the child windows in a cascade pattern.
Click Arrange Icons to arrange all iconified windows at the bottom of the workspace.
Click Next to navigate to next open window.
Click Previous to navigate to previous open window.
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 Viewing Files in the Pre-Production Editor During
Export
To view a DXF/DWG or Gerber/Drill file during export from ADS:

Select DXF/DWG or Gerber/Drill from File type drop-down list in Export dialog.1.
Select the View file after export checkbox and click OK.2.
This will display the exported DXF/DWG or Gerber/Drill file. A status window shows if
the export is complete or failed and the design is displayed in the Pre-Production
Editor.

 Viewing Files in the Pre-Production Editor During
Import
To view a DXF/DWG or Gerber/Drill file during import to ADS:

Select DXF/DWG or Gerber/Drill from File type drop-down list in Import dialog.1.
Click Preview to view the file in the Pre-Production Editor.2.

 Editing Files in the Pre-Production Editor
Using the Pre-Production Editor you can cut, copy, paste and modify designs. From the
Modify menu, you can perform editing functions like union, intersection, union minus
intersection, crop, and chop.

To edit using the Pre-Production Editor:

Open a design in the Pre-Production Editor as described above.1.
Click Edit > Edit Enable.2.

To cut a figure, select the figure and then click Edit > Cut.
To copy a figure, select the figure and then click Edit > Copy.

To crop or chop a figure:3.
Select the figure.1.
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Click Crop or Chop.2.
Mark the area to crop/chop using mouse.3.

Release the mouse to crop/chop the selected area.4.

Click Delete to delete selected item.4.
Click Undo to revoke last Edit command.5.
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 Cadence/PCB Translator
Cadence/PCB files are IFF files that are used to transfer schematic and layout data
simultaneously to Cadence Concept and Allegro PCB editors. This format is available from
the Advanced Design System layout menu only, yet it enables the transfer of both
schematic and layout information.

When you select the Cadence/PCB export format from an Advanced Design System Layout
window, both a layout and schematic IFF file are exported in a single step. The design
data is exported into a standard directory tree contained in the program's workspace
directory structure.  The standard directory is called to_cadence.

The exported files are placed within this directory in a subdirectory that is named the
same as the design being exported. This subdirectory contains an information file and the
translated schematic and layout IFF files. Thus, if you were translating a design called test
, the exported files (design_info, schematic.iff and layout .iff) would found in a directory
called to_cadence/test.hpxfer.

For information on how to import the files in the Cadence tools, consult the Cadence
Allegro PCB Editor user guide.

 Importing Cadence/PCB Files
This section outlines the procedure for translating designs from Cadence/PCB format. For
more information on transferring designs between the Advanced Design System and
Cadence Analog Design Environment, contact your Agilent Technologies sales
representative.

To import an Cadence/PCB file follow the steps as outlined in Importing a Layout (trans).
For available options (accessed via More Options in the Import dialog box), see Import
Cadence/PCB Options.

 Import Cadence/PCB Options
This section describes the definable options available for importing files in the
Cadence/PCB format. To view the options, click File > Import > Cadence/PCB > More
Options.

The Import Cadence/PCB Options dialog enables you to specify configuration an trace
handling to control the import of Cadence/PCB files.
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 Remove IFF File After Import

When this option is selected, the .iff file is removed once the file is successfully imported.
This option is not selected as the default.

 

 Log verbose messages

When this option is selected, ALL translation information is recorded in the ifftolib.log file
resulting in step-by-step description of what happened internally during your translation.
This option is primarily intended to be used as a diagnostics tool so the default mode for
this option is deselected. Note that error and warning messages will always appear in your
status window regardless of this selection.

  

 Synchronize ports to symbol using node name

When this option is selected, the IFF import resets the symbol pin numbers to match port
numbers based on the node name of the schematic port. By default, symbol pin numbers
are matched to schematic port numbers based on the port's instance name.

 

 Use port name for connected wire label

For each wire attached to a port, the wire label will be set to name of the port from the
Cadence environment. To maintain proper connectivity in the ADS environment, this
option must be enabled if connectors share a common name in the Cadence environment.
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 Use layouts from libraries instead of building local copies from IFF file

When this option is selected, library elements that already exist in the system libraries are
not recreated for the imported file. Instead, these elements are read from the local
libraries; if an element does not exist in a local library, then it is newly created. This
option is deselected as the default, and all elements are created/recreated in the local
workspace.

 

 Default Library Name For Library Parts

When the IFF file does not specify a library name for a component that needs to be
created, the library name specified in this field is used. This is necessary for environments
that do not support the concept of a library.

Note
The Default Library Name For Library Parts field is identical to the field of the same name in the Export IFF
Options dialog box. Changes made to this field will modify the contents of the field in the Export IFF
Options dialog box.

 
A component library in ADS consists of a collection of component definitions. Each
primitive component has an associated component name, symbol and predefined
component parameters that include relevant physical and electrical characteristics.

The IFF translator can be used as the initial step in creating an ADS component library
however, this topic is outside of the scope of this documentation. Creating an ADS
component library using IFF requires specialized tools and training. If you're interested in
learning more about this topic, contact Agilent EEsof-EDA's Solution Services.

 

 Trace Handling

Trace Handling enables you to select how you want your meander elements interpreted
during a translation.

Trace When this option is selected, meander elements are translated as simulatable
traces with pins. This is the default setting.
Path When this option is selected, meander elements are translated as primitive data
type with center line and width. The default for this option is deselected.
Polygon When this option is selected, meander elements are translated as polygons. The
default for this option is deselected.

Note
If you choose Use layouts from libraries instead of building local copies from IFF file in the Import IFF
Options dialog box, choose Path in the Trace Handling options. Fixed artwork is not simulatable, therefore
it is not necessary for the interconnects to be simulatable.

 

 Exporting Cadence/PCB Files
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This section outlines the procedure for translating designs into Cadence/PCB format. For
more information on transferring designs between the Advanced Design System and the
Mentor Graphics Falcon Framework, contact your Agilent Technologies sales
representative.

To export an Cadence/PCB file:

Follow the steps as outlined in Exporting a Layout (trans). For available options1.
(accessed via More Options in the Export dialog box), see Export Cadence/PCB
Options.
If the option Prompt For User Message was selected, an Export Cadence/PCB Options2.
message dialog appears:

 Enter any messages to be included with the design transfer. This information is used
only by the import_hpeesof utility (see Cadence/PCB Files) and is not kept with the
design.
If you do not wish to include a message in the file, you may leave this window
empty. If you want to print the message, click Print.
To proceed with the transfer, click OK.
When the translation is completed, the following message window appears:3.

Click OK to dismiss this window.
The IFF Export log appears:4.
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Review the log, searching for any warnings or error messages generated during
export.
The log file appears in the hpeesofeedit window by default. This window is provided
as a means of viewing the file and is not intended for editing.
To dismiss the log window, choose File > Quit.   5.

 Export Cadence/PCB Options

  

 IFF File Overwrite Options
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 Overwrite IFF File
When writing to an existing file, the contents of that file are overwritten. This is the
default setting.
Append to IFF File
When writing to an existing file, the new data is appended to the existing file.

 

 Default Library Name For Library Parts

 The name of the library to which the library parts are written. Design objectives are
stored in a group that uses the same name as the workspace directory, but library parts
are stored in either the default library hpeesoflib or a library that you specify.

Note The default library name can contain only alphabetic and numeric characters.

 

 Output disabled instances to the IFF file

When this option is selected, if an instance is disabled in the schematic, it will still be
output into the IFF file. If the checkbox is deselected (default), disabled instances will not
be exported. This option can be utilized to omit certain components from being transferred
to remote environments that might not support the components (e.g. disable the
simulation components prior to creating an IFF file to send to Cadence, which does not
have any definitions for the simulator components). Activate this option if you want to get
everything. Deactivate this option if you want to filter out the unused/unwanted
components.

 

 Output ADS Item Definition properties

When this option is selected, ADS Item Definition properties are utilized to recreate the
information necessary to simulate a component for ADS. For example, if you have
parameters on a resistor, some Item Definition properties are created in the IFF file (e.g.
R_ADS_UNIT=1), which allow the IFF importer to exactly recreate the component as it
exists in ADS. However, other tools will not recognize the Item Definition parameters, and
may misinterpret the properties as being separate. If library symbols are being exported
to other environments that do not recognize the ADS Item Definition parameters, the
option should be turned off. This option is deselected by default.

 

 Put a space between numbers and the scalar/unit

When this option is selected, parameter values are exported as they normally appear in
ADS (i.e. with a space between the number and the scalar, e.g. "1 pF"). If the checkbox is
deactivated, the exporter converts the values into the IFF value specification, which is to
have no space between a number and a scalar (e.g. "1pF"). Ideally, an IFF exporter
should interpret either form of number, and set the value internally to whatever is normal
for that environment. Some environments do not interpret the IFF property values in any
way and can exhibit problems with the values when they are imported.
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 Schematic Hierarchy Option

This establishes how much of the schematic hierarchy is exported:

Current Design Only Write current level only. Complete design information for the
current design is exported. Instance-specific information (parameter values and
coordinates identifying position) is also exported. Detailed definitions of a referenced
design are not exported.
Current Design and All Library Parts Complete design information for the current
design is exported. Referenced designs that reside in a library selected for inclusion
during export and are part of the current design's hierarchy are also exported. In
addition, library parts are exported.

   

 Library  

Displays the current library. If hierarchical, all included libraries are listed in the
appropriate order.

 

 Libraries Included During Schematic Export

 The libraries for which schematic design information is exported. You may customize this
list if the current library is hierarchical. (Note that complete layout hierarchy is always
exported.)
To add a library to this list:

In the Library list, click the desired library.

Click Include. The library is added to the Libraries Included list.1.
To include all Libraries, click Include All.2.

To remove a library from the Libraries Included list:

In the Libraries Included list, click the entry you want to remove.1.
Click Remove. The library is removed from the list.2.

To remove all entries from the Libraries Included list, click Remove All.

 

 Prompt For User Message

 When selected, a user message window appears before the transfer is initiated. This
window enables you to enter any messages that you want included in the translated file.
For more information about the user message, see Export Cadence/PCB Options.

This option is selected as the default.
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 DXF/DWG Translator
The DXF/DWG translator enables you to convert ADS designs into AutoCAD's DXF/DWG
file format, as well as convert DXF/DWG files into ADS designs. DXF is a very simple file
format that can be read by most CAD programs that support DXF. The DXF/DWG
translator is bidirectional and provides support for hierarchical and all layer separation.

DWG is a binary format, therefore the files take less time to load and save. ADS supports
importing and exporting to/from AutoCAD. AutoCAD versions 12 to 2007 are supported for
import. AutoCad versions 2000, 2004 and 2007 are supported for export. Carefully
consider how you want to use DXF/DWG output - including layer numbering, use of holes,
and polygon shapes - before beginning your layout design. Setting up the proper layout
rules in ADS can save a lot of time in generating acceptable DXF/DWG output. For specific
considerations or limitations, consult your AutoCAD documentation.

Note
Password protected DWG files are not supported.

ADS includes an editor that can display the DXF/DWG design. Using the editor, you can
compare the DXF/DWG files to the original ADS layout design to verify that the design was
exported correctly. Similarly, DXF/DWG files can be previewed prior to import into ADS:

to edit a large design down to a smaller design prior to importing it into ADS. This
edited design can be saved and then imported in ADS.
or after import, to verify that the DXF/DWG design data and the ADS-imported
design appear similar.

For details, see Using the Pre-Production Editor (trans).

 

 Importing DXF/DWG Files to ADS
The procedure for importing each format is generally the same, however the available
options differ. For a step-by-step tutorial on importing a layout file, refer to Importing a
Layout (trans). For specific import options related to importing DXF/DWG files, refer to
More Options. For information on mapping DXF/DWG entities to ADS layout components,
refer to Mapping DXF to ADS.

This section describes the definable options available for importing files in the DXF/DWG
format. To view the options:

Click File > Import from the Layout window.1.
Select DXF/DWG from the File type list box.2.
Enter the Import file name and Layers file name in the appropriate fields.3.
Click More Options... to open the More Options dialog box.4.

 
The More Options dialog box enables you to specify flattening and layers to control the
import of DXF/DWG format files. A DXF/DWG file and layers file must be selected in the
main export dialog for the More Options dialog box to open.
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 DXF Options

 Flatten Hierarchy

Select Flatten Hierarchy to remove any hierarchy that may be present in the DXF/DWG
selected. Default setting retains the hierarchy.

Note
If you select a DXF/DWG file that contains more than 50 component designs this option gets automatically
enabled in order to avoid long import times.

 Units

Older versions of the DXF file format may not specify units. If no Units were specified in
the input DXF file, this option is enabled. Default setting is mil.

If the unit mentioned in the import file is different form layout unit then a warning
message (trans) is displayed.

 Layer Options
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The Layer tab displays a list all the layers in DXF/DWG file. Layers can be selectively
imported to ADS using the import column. By default all layers are imported. Using this
tab user can map DXF/DWG layers to ADS layers during import. By default DXF/DWG
layers are mapped to ADS layers with same name. If no match is found the mapped layer
is Mismatch. During import if a Mismatch mapping is encountered a new layer with same
name as DXF/DWG layer name is created in current workspace technology in ADS.

User can save layer mapping in .map file using Save Mapping button.
During import user can load a previously saved layer mapping file (.map) using Load
Mapping button.

Note
Set the Arc/Circle resolution (degrees) value before importing the DXF/DWG file. From the Layout window,
click Options > Preferences. From the Preferences dialog box, click Entry/Edit tab and change the
Arc/Circle resolution (degrees) field.

 Mapping DXF to ADS

The following table represents the mapping of DXF/DWG file shapes to ADS file shapes.

 Mapping DXF File Shapes to ADS File Shapes



Advanced Design System 2011.01 - Importing and Exporting Designs

35

DXF/DWG ADS Layout Equivalent

Line with width = 0 Polyline

Line with width > 0 Path

Polygon with width = 0 Polygon

Polygon with width > 0 Polygon with cutline

Rectangle with width = 0 Rectangle

Rectangle with width > 0 Polygon with cutline

Circle with width = 0 Circle

Circle with width > 0 Polygon with cutline

Arc with width = 0 Arc

Arc with width > 0 Polygon

  
 

 Exporting an ADS Design to DXF/DWG Files
To export DXF/DWG files:

Follow the steps as outlined in Exporting a Layout (trans). For available options1.
(accessed via More Options in the Export dialog box), see Export DXF/DWG Options.
After clicking OK in the Export dialog box, the translator converts your ADS Layout to2.
DXF format.

Once in DXF/DWG file format, the file is available for use in AutoCAD or other Mechanical
CAD systems.

 Export DXF/DWG Options

The More Options dialog box enables you to set file format, Autocad version, path
geometry, and hole format.
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 Options

The Options tab enables you to select various design attributes and AutoCad File Formats
in the translation.

 File format

DXF (Text)

Select this option to export the ADS design to DXF format as an ASCII text file. This
selection is the default settling.

DWG

Select this option to export your ADS design to a binary DWG file format. Exporting to
DWG file format is faster than the DXF (Text) format. Also file size of the DWG file will be
smaller as compared to corresponding DXF (Text) file.

 Autocad version

Use this drop-down list to select the AutoCad version. ADS layout can be exported in three
AutoCad versions: 2000, 2004, and 2007.

 Paths as polygons

Select Paths As Polygons to export the design paths or traces as polygons. Paths or
traces have mitered or curved corners that need to be preserved in the translation. The
ADS layout has paths with endpoint types other than flush that need to be preserved in
the program database. This option is selected as the default.

 Text as polylines

Select Text as polylines option to convert all layout text to set of polylines. The fonts are
maintained as in layout.

 Hole format

The Hole format section enables you to define how the translator deals with holes in a
design.

Holes as polygons

Select Holes As polygons to convert holes into polygons. One polygon will be created for
each hole in the same layer.

Note
Some systems may not be able to tolerate complex polygons with cutlines. For these systems, select
Holes as polygons. This option is deselected as the default.

Holes as cutlines

Select Holes as cutlines to convert holes into cutlines. This option is selected as the
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default.

 Layers

The Export column enables you to deselect one or more layers to exclude it from the
output file. Default setting is all layers selected and exported.

 Mapping ADS to DXF (hierarchical)

The DXF file created by the DXF/DWG translator is as simple as possible so that many DXF
parsers, even primitive ones, can read the file. The DXF translator performs the following
mapping between ADS Entity and DXF files.

 Hierarchical DXF Output

ADS Entity DXF Entity

Polygon closed LWPOLYLINE, solid HATCH

polyline open LWPOLYLINE

path closed LWPOLYLINE, solid HATCH

wire open LWPOLYLINE

circle circle

text text

rectangle closed LWPOLYLINE, solid HATCH

arc arc
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 EGS Archive Files
The EGS Archive format is an ASCII text format that represents multiple hierarchical
designs. EGS Archive files include information such as drawing shapes, layout units,
database precision, grid spacing and, optionally, a layers definition including layer colors,
numbers, and names. They do not contain information about the connectivity of a layout
design.

Originating from a former Hewlett-Packard product called the Engineering Graphics
System (EGS), the EGS Archive format is useful as an intermediate file for transferring  
input/output to various third-party translators. It is also the best format for translating
graphic shapes into the  Series IV and MDS products. In addition, the EGS Archive format
is easy to parse and read, so if you have created your own software tools, this is a very
useful format for transferring graphics shapes into these tools.

When importing an EGS Archive file into Advanced Design System, you may specify a
Layers File Nam e for the creation of a layers definition file (the Layers File Name field is
located in the Import dialog box). This file will be automatically created and will contain
the layer information from the EGS Archive file, as well as layers automatically added as
necessary during import. All designs created during import reference this layers file.

Oval or hatch shapes of the EGS Archive format are not supported in Advanced Design
System.

  

 Importing EGS Archive Files  
The procedure for importing each format is generally the same, however the available
options differ. For a step-by-step tutorial on importing a layout file, refer to Importing a
Layout (trans). For specific import options related to importing EGS Archive Files, refer to
Import EGS Archive Options. For information on mapping EGS Archive files to ADS, refer
to Mapping EGS Archive to ADS.

 

 Import EGS Archive Options

There are no definable options available for importing files in the EGS Archive format.

  

 Mapping EGS Archive to ADS

The table below shows the mapping of EGS Archive file shapes to Advanced Design
System layout shapes.



Advanced Design System 2011.01 - Importing and Exporting Designs

39

EGS Archive Object Advanced Design System Layout Equivalent

Line with width = 0 Polyline

Line with width > 0 Path

Polygon with width = 0 Polygon

Polygon with width > 0 Polygon with cutline on longest segment

Rectangle with width = 0 Rectangle

Rectangle with width > 0 Polygon with cutline on longest segment

Circle with width = 0 Circle

Circle with width > 0 Polygon with cutline to the right

Arc with width = 0 Polyline

Arc with width > 0 Polygon

   

 Exporting EGS Archive Files 
The procedure for exporting each format is generally the same, however the available
options differ. For a step-by-step tutorial on exporting a layout file, refer to Exporting a
Layout (trans). For specific export options related to exporting EGS Archive Files, refer to
Export EGS Archive Options. For information on mapping ADS to EGS Archive files, refer
to Mapping ADS to EGS Archive.

 

 Export EGS Archive Options

To explore Export EGS Archive Options, in Layout window, click File > Export > EGS
Archive Format > More Options.

   

 Include Mask Layers  

When this option is selected, a list of mask layers is included with the translated design.
This option is selected as the default.
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 Paths As Polygons

When Paths As Polygons is selected, the design paths or traces are exported as polygons.
This should be selected for the following conditions:

Paths or traces have mitered or curved corners that need to be preserved in the
translation.
T he EGS Archive file has paths with endpoint types other than flush that need to be
preserved in the program database.

This option is deselected as the default.

  

 Holes As Polygons

When this is selected, holes are converted to polygons. When Holes As Polygons is not
selected (this is the default), polygons with holes are translated as single-segment
polygons, the false edge segment becoming part of the polygon. Some systems may not
be able to tolerate this type of complex polygon. For these systems, select Holes As
Polygons .
This option is deselected as the default.

  

 Flatten Components

When Flatten Components is selected, all instances whose artwork type is defined with an
AEL macro will be flattened when exported. For example, if a design contains an MLIN it
will be flattened. This option is deselected as the default. It only affects the current design
and will not change the hierarchy.

  

 All Filled

When this is selected, all data is transferred as filled. This option is deselected as the
default.

  

 Flatten All

When Flatten All is selected, all levels of hierarchy are automatically removed and a single
flat design is exported. There are no references from the top-level structure to any other
structure in the design. This option is useful when your post-processor does not support or
correctly translate hierarchy in EGS Archive files. Please note: if a substructure was
instanced more than once, selecting this option can substantially increase the size of the
file.
This option is deselected as the default.
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 Auto Merge

When Auto Merge is selected, all shapes for every mask layer that intersect or overlap are
merged. This option is deselected as the default.

 

 Layers To Exclude

Layers can be excluded from the EGS Archive export by entering the layer IDs. Multiple
IDs can be entered using space or comma delimiter.

  

  

 Mapping ADS to EGS Archive

The table below represents the mapping Advanced Design System layout shapes to EGS
Archive file shapes.

Advanced Design System Layout Object EGS Archive Equivalent

Polyline Line

Path with PathsAsPolygons Polygon

Path without PathsAsPolygons Line

Circle Circle

Rectangle Rectangle

Polygon Polygon

Wire Line
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 EGS Generate Files
The EGS Generate format is an ASCII text format representing a single, flat design. It is a
subset of the EGS Archive format that contains only the shape information. If an
hierarchical design is exported, it is automatically flattened during the export process.

Originating from a former Hewlett-Packard product called the Engineering Graphics
System (EGS), the EGS Generate format is useful as an intermediate file for transferring  
input/output to various third-party translators. Also, the EGS Archive format is easy to
parse and read, so if you have created your own software tools, this is a very useful
format for transferring graphics shapes into these tools.

When importing an EGS Generate file into the Advanced Design System, you may specify
a Layers File Nam e for the creation of a layers definition file (the Layers File Name field is
located in the Import dialog box). This file will be automatically created and will contain
the layer information from the EGS Generate file, as well as layers automatically added as
necessary during import. All designs created during import reference this layers file.

Oval or hatch shapes of the EGS Generate format are not supported in the Advanced
Design System.

  

 Importing EGS Generate Files
The procedure for importing each format is generally the same, however the available
options differ. For a step-by-step tutorial on importing a layout file, refer to Importing a
Layout (trans). For specific import options related to importing EGS Generate Files, refer
to Import EGS Generate Options. For information on mapping from EGS Generate files to
an ADS layout, refer to Mapping EGS Generate to ADS.

 

 Import EGS Generate Options  

There are no definable options available for importing files in the EGS Generate format.

  

 Mapping EGS Generate to ADS

The table below represents the layout mapping from EGS Generate format to Advanced
Design System layout.
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EGS Generate Object Advanced Design System Layout Equivalent

Line with width = 0 Polyline

Line with width > 0 Path

Polygon with width = 0 Polygon

Polygon with width > 0 Polygon with cutline on longest segment

Rectangle with width = 0 Rectangle

Rectangle with width > 0 Polygon with cutline on longest segment

Circle with width = 0 Circle

Circle with width > 0 Polygon with cutline to the right

Arc with width = 0 Polyline

Arc with width > 0 Polygon

   

 Exporting EGS Generate Files  
The procedure for exporting each format is generally the same, however the available
options differ. For a step-by-step tutorial on exporting a layout file, refer to Exporting a
Layout (trans). For specific export options related to exporting EGS Generate Files, refer
to Export EGS Generate Options. For information on mapping ADS to EGS Generate files,
refer to Mapping ADS to EGS Generate.
 

 Export EGS Generate Options

To explore Export EGS Generate Options, click File > Export > EGS Generate Format >
More Options.

   

 Include Mask Layers  

When this option is selected, a list of mask layers is included with the translated design.
This option is selected as the default.

  

 Paths As Polygons
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When Paths As Polygons is selected, the design paths or traces are exported as polygons.
This should be selected for the following conditions:

Paths or traces   have mitered or curved corners that need to be preserved in the
translation.
The EGS Generate file  has paths with endpoint types other than flush that need to
be preserved in the program database.

This option is deselected as the default.

  

 Holes As Polygons

When this is selected, holes are converted to polygons. When Holes As Polygons is not
selected (this is the default), polygons with holes are translated as single-segment
polygons, the false edge segment becoming part of the polygon. Some systems may not
be able to tolerate this type of complex polygon. For these systems, select Holes As
Polygons.
This option is deselected as the default.

  

 All Filled

When this is selected, all data is transferred as filled. This option is deselected as the
default.

  

 Auto Merge

When Auto Merge is selected, all shapes for every mask layer that intersect or overlap are
merged. This option is deselected as the default.

 

 Layers To Exclude

Layers can be excluded from the EGS Archive export by entering the layer IDs. Multiple
IDs can be entered using space or comma delimiter.

  

 Mapping ADS to EGS Generate

The table below represents the layout mapping from Advanced Design System layout to
EGS Generate format.
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Advanced Design System Layout Object EGS Generate Equivalent

Polyline Line

Path with PathsAsPolygons Polygon

Path without PathsAsPolygons Line

Circle Circle

Rectangle Rectangle

Polygon Polygon

Wire Line
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 Gerber Translator
The Gerber Artwork Translator translates artwork directly from circuit layouts created with
Advanced Design System into Gerber format. It exports ADS layouts into ASCII files that
control Gerber photo-plotting equipment.

ADS includes an editor that can display the Gerber/Drill design. Using the editor, you can
compare the Gerber/Drill files to the original ADS layout design to verify that the design
was exported correctly.

For details, see Using the Pre-Production Editor (trans).

 Gerber Command Format
The Gerber format is a numerical control language developed to generate photo artwork.
The output of this translator is an ASCII file that contains the following Gerber commands:

G01 = linear interpolation
G54 = aperture select
D01 = shutter open
D02 = shutter close
D03 = flash
M02 = end of program
X and Y = coordinates
* = end of block

 Coordinates are absolute, with implied decimal point and optional leading zero
suppression. However, the literal string values may be modified in the message file. For
example, G01 may be changed to AB. A sample listing of the Gerber file commands, with
interpretation to the right, might look like this:

This example would produce the following:
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The output file (Gerber command file) is the Gerber Drawing File (.gbr).

 

 Importing Gerber/Drill Files
The procedure for importing each format is generally the same, however the available
options differ. For a step-by-step tutorial on importing a layout file, refer to Importing a
Layout (trans). For specific import options related to importing Gerber/Drill files, refer to
More Options. While importing Gerber/Drill files multiple files can be selected at a time.
The drill files are imported in seperate drill layers. For example a drill file named cond.drl
is imported in layer cond_drl in ADS.

Note
Only RS274X and MDA formats are supported in gerber import.

This section describes the definable options available for importing files in the Gerber/Drill
format. To view the options:

Click File > Import from the Layout window.1.
Select Gerber/Drill from the File type list box.2.
Enter the Import file name and Layers file name in the appropriate fields.3.
Click More Options... to open the More Options dialog box.4.

The More Options dialog box enables you to specify units, number format, mode, zero
suppresion and layers to control the import of Gerber/Drill format files. A Gerber/Drill file
and layers file must be selected in the main Import dialog box for the More Options dialog
box to open. User options preferences are saved in setup_gerber.opt file.

 Gerber/Drill Options
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 Units

Older versions of the Gerber file format may not specify units. If no Units were specified in
the input Gerber file, this option is enabled. Default setting is inch.
 
If the unit mentioned in the import file is different form layout unit the following warning
message is displayed.

For step-by-step tutorial on creating a new library, refer to Creating Libraries (adstour).
To change the units of the current library refer to Technology Setup (usrguide). Click OK
to continue importing on current layout.

If you check the Do not show this dialog automatically. check box then no unit mismatch
warning message is displayed. To display the warning message box again edit
%HOME%/config/de_sim.cfg and set the value of UNIT_WARNING environment variable
to TRUE.
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Note
This Unit Warning also appears if there is a unit mismatch while importing DXF, ODB__, and Mask files.

 Number format

The number of integers placed before and after the decimal point. If no number format is
specified in the gerber file, then this option is enabled. While importing multiple files
together the number format specified in the first gerber file is used for all other files. For
drill files if number format is not set in the file itself user can specify the number format.
The default is 2.4.

 Mode

If no Mode is set in gerber file this option is enabled. The default Mode setting is Absolute.

 Zero Suppression

Available settings are Leading and None. If zero suppression is not specified in the Gerber
file this option is enabled. The default setting is leading zero suppression.

 Automerge

By default, the Automerge option is unchecked. The figures are merged during the
import if the Automerge option is checked.

 Layers Options

The Layers tab displays a list all the layers in Gerber file. Layers can be selectively
imported to ADS using the import column. By default all layers are imported.
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 Drill diameter Options

The Drill diameter tab allows user to set drill diameter during import. This is particularly
useful when the drill diameter is not mentioned in the file or mentioned in seperate drill
header file.

Note
Since the Gerber and drill files have seperate options it is recommended to import Gerber and drill file
seperately in same layout.

 Exporting Gerber Files
This tool can generate Gerber files in RS274X and MDA format for raster photo plotters.

The Gerber export tool creates one output file for each different layer used in the layout
design. For example, if the design contains two layers, cond and cond2, two Gerber files
will be generated:

cond.gbr
cond2.gbr

To export the Gerber files:

In the layout window containing your design, choose File > Export.1.
The Export dialog box opens.
In the File type field, select Gerber/Drill.2.
Optionally, you can select the View file after export check box to open the Pre-3.
Production Editor where you can compare the Gerber files to the original ADS layout
design to verify that the design was exported correctly. For details, see Using the
Pre-Production Editor (trans).
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To define export options, click More Options.4.
Set the options that apply.5.
For available options, see Gerber File Options.
Click OK to save your settings or Cancel to retain the default settings.6.
In the Destination Directory field, accept the default directory, or click Browse to7.
locate a new destination directory.
The destination directory will be the <Workspace Dir>/mfg/<Design Name>/gerber/
where:
<Workspace Dir> is the workspace directory
<Design Name> is directory named with the design name
Click OK to export the ADS layout design to a Gerber file.8.
A Status window appears detailing the export information.

Examine the log, searching for any warnings or errors that may have occurred during9.
translation.
To save the log message in a file: select the text, copy, and then paste into any text
editor.

 Gerber File Options

You can view or edit the translator settings, by clicking More Options in the Export dialog
box.

More Options dialog opens, providing access to these options.
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Gerber file choices can be edited in the Options tab.

 File format

Select RS274X for an enhanced version of Gerber RS274D format that supports
embedded apertures and G36/G37 polygons.
Select MDA if your photoplot shop uses a FIRE 9000 plotter. It embeds apertures
and supports POEX/POIN polygons for fill on the fly.

 Hole format

In ADS, when a hole is created in a geometrical figure (like polygon), a cutline is
introduced. This is a false edge connecting the outer boundary of the polygon with the
inner boundary. This polygon is actually a single re-entrant polygon. When you select
Holes as cutlines this re-entrant polygon is translated to Gerber as-is. The default is
Holes as cutlines.

 Holes as Cutlines

Select Holes as polygons or Preserve holes to remove the false edge from the
polygon.

 Holes as Polygons



Advanced Design System 2011.01 - Importing and Exporting Designs

53

When Holes as polygons is selected, holes are exported as filled elements. Therefore the
polygon will appear to have no holes.

 Preserve holes

When Preserve holes is selected, the resultant polygon in Gerber contains a dark area
and empty area. This option is not available for exporting Gerber files in RS274X format.

 Unit

Available units are inch or mm. Inch is the default.

 Number format

The number of integers placed before and after the decimal point. If chosen incorrectly,
Gerber data resolution can be poor. The default is 2.4. If the unit is set to mm then you
can set the number format to 3.3.

A warning message is displayed in the Status window to notify the user that to preserve
the precision in the Gerber data, number format has to be selected carefully. If the Gerber
data is not generated correctly for the selected number format then a suitable error
message is displayed in the Status window.

 Zero suppression

Available settings are Leading and None. Select Leading (the default) to remove all
leading zeros in the coordinate data, making the Gerber file smaller.

 Scale

Set Scale to a value other than 1.0 to scale the design during Gerber export.

Note
The drill data is scaled by the same scale factor. The polyline width set in the dialog is not scaled.

 Line width for polylines
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Polylines in ADS have zero width, but you can use this option to provide a width to be
used for drawing this polyline in the Gerber file.

If the polylines and arcs (both zero width entities) are not required to be exported, then
set the width to zero.

 Gerber Layer Options

All the layers used in the design are displayed in a table in the Layers tab of the More
Options dialog. By default, all the layers will be displayed with positive polarity and all
layers will be exported. You can avoid exporting a specific layer by deselecting the
checkbox in the Export column for that layer.

 Limitations and Considerations

No intermediate mask file is generated.
The new Gerber export tool is targeted for the raster photoplotters to generate
RS274X and MDA file format.
No aperture filling is supported for polygons.
No separate aperture file is required for RS274X and MDA files.
It is recommended to create the ADS design using inch or mm as the unit and set the
appropriate resolution.
You must set the appropriate number format in the More Options dialog so that the
precision in Gerber data is more than the precision in layout design.

 Exporting Drill Files
In ADS, drill file export is accomplished simultaneously as part of the Gerber export. The
procedure for generating the drill file is similar to generating the Gerber file.
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Drill files are configured from the Drill tab in the More Options dialog.

Select the checkbox to designate the layer for which you want to generate the drill file.
When a layer is selected, all the tools on that layer are automatically selected. By default,
no drill file will be generated during Gerber export.

The drill file options Number format, Output unit, and Zero suppression are same as
options set for Gerber export in Options tab of More Options dialog. However, note that
the zero suppression in Drill is actually a zero inclusion.

Tool Dia. (Diameter) is an editable field. By default the Tool Diameter value equals the
Drawing Diameter value.

 Considerations:

If a layer does not have any via (circles) then it will not be displayed in the Drill table
and no drill file will be generated for that layer.
One drill file will be generated for each layer.
Drill files will be created in the Destination directory selected in the Export dialog.
Drill file name is the same as layer name with extension .drl. For example, drill file
for the layer cond will be cond.drl.
If Tool Diameter is set to 0.0, the Tool Diameter will be equal to the Drawing
Diameter in the output drill file.
The drill data is scaled by the factor set by Scale on the Options tab.
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 GDSII Stream File Translator
In this section:

Introduction
Importing GDSII Files to ADS
Exporting an ADS Design to GDSII

 Introduction
The end result of many MMIC designs is a Calma or GDSII stream format file. Advanced
Design System's Layout provides a flexible GDSII translator for both reading and writing
this format. The GDSII Stream File Translator is a bi-directional graphics file translator. It
can create files in GDSII Stream file format from Advanced Design System layouts, and it
can translate graphics files from GDSII Stream file format into Advanced Design System
layouts.

The Advanced Design System to GDSII Stream file format translation links the Advanced
Design System directly to mask-making equipment that uses the popular GDSII Stream
file format. This format, in turn, gives access to a wide range of photoplotters,
coordinatographs, E-beam machines, and pattern generators. The GDSII Stream file
format to Advanced Design System format translation makes it easy to use the  cell
libraries offered by many GaAs semiconductor foundries.

Translation from a layout in the Advanced Design System into GDSII Stream file format is
done with the menu command File > Export > GDSII Stream Format.

 

The table below describes GDSII elements and their Advanced Design System layout
equivalents.

 Table: GDSII Elements and their ADS Layout Equivalents

Calma/GDSII Element Layout Equivalent(s)

Box element Rectangle

Boundary element Polygon, Rectangle

Path element Polygon

Boundary element Circle, Polygon

Element Text

Boundary element Hole

Structure element Design

Sref element Instance

None Pin

Path element Wire

Path element Trace

Plex None

Array Instances

Node None
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 Importing GDSII Files to ADS
The Advanced Design System reads GDSII files into a layout design without circuit or
schematic information, internally converting the drawing data to the current layout units.
For a step-by-step tutorial, see Importing a Layout (trans). For import options, see Import
GDSII Options.

 
To import GDSII files to ADS:

Click File > Import > GDSII Stream Format1.
Enter the Import file name and Layers file name in the appropriate fields2.
Click More Options...3.

 Import GDSII More Options

The More Options dialog enables you to specify flattening and layers to control the import
of GDSII format files. A GDSII file and layers file must be selected in the main export
dialog for the More Options dialog to open.

 Figure: Options for importing GDSII files to ADS

You can Check/Uncheck/specify information in the following check/edit boxes:

 Ignore box records

This option specifies that GDSII Box Records are not translated. By default, Box Records
are translated as rectangles.

 Overwrite existing cells

If this option is checked, GDSII import will overwrite an existing design with the imported
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data. If this option is omitted, any cell in the GDSII file that corresponds to a pre-existing
design is silently skipped. By default existing cells are overwritten.

 Text height

This option specifies the text height for labels. The default value is 1 user unit.

 Hierarchy

 Import entire hierarchy

If selected GDSII import imports entire hierarchy.

 Hierarchy depth

Specifies the depth of hierarchy to import. The default hierachy depth is 20.

 Layers

 Figure: Layer options for importing GDSII files to ADS

 

Layer tab allows you to perform a layer mapping between ADS Layer purpose, GDS Layer,
and GDS Datatype during import. The following details are listed for layers under Layers
tab:

Layer name
Layer purpose
GDS layer
GDS datatype
Import

Importer creates GDSII objects on the ADS layer and purpose found in the technology
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library using the GDS Layer Number and GDS Datatype specified in the mapping. GDSII
objects on GDS Layer and GDS Datatype combinations not found in the mapping are not
translated. Default layer mapping or Automap, creates GDSII objects on same layer and
purpose as GDS Layer and GDS datatype. If no layer is found for GDS layer and purpose a
new layer L<GDS Layer Number> and P<GDS Datatype> is created in the technology.

You can create a custom layermap file for layer mapping in the following format:

<ADS Layer Name> <ADS Layer Purpose> <GDS Layer Number> <GDS Purpose>

Lines in the layerMap file that are blank and lines beginning with the comment character #
are ignored by the importer.

Click on the following buttons to perform the following actions:

Add row - Adds a new row in the layers list.
Delete row - Deletes selected row.
Load mapping - Allows user to browse and load an already defined layermap file.
The loaded custom map is remembered by the importer for a single ADS session.
Restart ADS to reset layer mapping to default mapping or automap.
Save mapping - Allows user to save the layer map file.
AutoMap - Enables automatic mapping. With Automapping during import, GDSII
layers and purpose are translated to L<GDSLayer> and P<GDS Datatype> in ADS.
During Export with automap, objects are created in same GDSII layer and purpose as
ADS. Click Automap to clear any prevously loaded custom layer map.

Click OK to import GDSII files to ADS.

 Exporting an ADS Design to GDSII
To export GDSII files:

Follow the steps as outlined in Exporting a Layout (trans).1.
After clicking OK in the Export dialog box, the translator converts your ADS Layout to2.
GDSII format.

Once in GDSII file format, the file is available for use in AutoCAD or other Mechanical CAD
systems.

 

 Export GDSII More Options

The Export GDSII More Options dialog box enables you to select the geometry and
hierarchy options.

 Options

 Figure: Options tab for exporting GDSII files
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You can Check/Uncheck/specify information in the following check/edit boxes:

 Geometry

 Output rectangles as box

Selecting this option generates output rectangles as box.

 Flatten

Selecting this option flattens a hierarchical design.

 Conform to 32 character structure name limit

Selecting this option will not allow you to enter more than 32 characters for a structure
name.

 Export annotations

Selecting this option will enable you to export annotations.

 Hierarchy

 Export entire hierarchy

If selected GDSII exports entire hierarchy.

 Hierarchy depth

Specifies the depth of hierarchy to import.

 Layers
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 Figure: Layer options for exporting GDSII files

Layer tab allows you to perform a layer mapping between ADS Layer purpose and GDS
Layer and GDS Datatype. The following details are listed for layers under Layer tab:

Layer name
Purpose name
GDS layer
GDS purpose
Export

Objects on ADS layer and purpose combinations found in the mapping are created on the
GDS layer and datatype specified in the mapping. Objects on ADS layer and purpose
combinations not included in the mapping are not created in GDS file. Default layer
mapping or Automap creates GDS object on same layer and datatype as in ADS layer and
purpose.

User can create custom layer mapping file for the purpose of export. The format of layer
mapping file is

<ADS layer name> <ADS layer purpose> <GDS layernumber> <GDS datatype>

Click on the following buttons to perform the following actions:

Add row - Adds a new row in the layers list
Delete row - Deletes selected Row
Load mapping - Allows user to browse and load an already defined layermap file.
The loaded custom map is remembered by the exporter for a single ADS session.
Restarting ADS resets layer mapping to default mapping or automap.
Save mapping - Allows user to save the layer map file.
AutoMap - Enables automatic mapping. During Export with automap, objects are
created in same GDSII layer and purpose as ADS. Click Automap to clear any
prevously loaded custom layer map.
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 HPGL/2 Files 
The HPGL/2 format is a subset of the HPGL22 printer/plotter language and can be
exported from a Layout.

 Exporting HPGL/2 Graphics Files    
The procedure for exporting each format is generally the same, however the available
options differ. For a step-by-step tutorial on exporting a layout file, refer to Exporting a
Layout (trans). For specific export options related to exporting HPGL/2 Files, refer to
Export HPGL/2 Options.

 

 Export HPGL/2 Options

The Export HPGL/2 Options dialog box enables you to set Units and Precision.

 
  

 Units

These are the units with which the HPGL/2 file will be exported. You may select from the
following options: same, mil, inch, um, mm, cm. The default is same. When same is
selected, the design is written in the same units that are stored in the design file. For
more information on choosing layout units, refer to Setting Layout Options > Preferences
for Layout > Setting Units/Scale Factors in Customization and Configuration (custom). 

  

 Precision

This value should be the same as the precision with which the drawing file was created. A
warning is generated if the precision is less than the drawing file precision. Possible values
are −2 and −3. The default is −3.
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 IFF Files
The Intermediate File Format (IFF) is an ASCII intermediate file. The file has a simple,
line-oriented command structure with a fairly rich set of constructs, thus simplifying
design transfer between Agilent Technologies products and third-party EDA tools. This
format is machine- and application-independent.

The types of information that can be represented in the IFF format include:

Design Objects
Symbols
Layouts
Schematics

Connectivity
Design Object Hierarchy
Hierarchical and Design Object Properties

IFF files are used as the exchange mechanism when transferring designs between
Advanced Design System and third-party EDA tools such as Mentor Graphics Design
Architect and Cadence Analog Artist.

  

 Importing IFF Files
 
The procedure for importing each format is generally the same, however the available
options differ. For a step-by-step tutorial on importing a layout file, refer to Importing a
Layout (trans). For specific import options related to importing IFF Files, refer to Import
IFF Options.

   

 Import IFF Options 

The Import IFF Options dialog box that appears is dependent upon where you execute the
IFF import from.

 Importing from a Layout Window

If the import is invoked from the Layout window, the following Import IFF Options dialog
box appears.
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 Remove IFF File After Import

When this option is selected, the .iff file is removed once the file is successfully imported.
This option is not selected as the default.

 

 Log verbose messages

When this option is selected, ALL translation information is recorded in the ifftolib.log file
resulting in step-by-step description of what happened internally during your translation.
This option is primarily intended to be used as a diagnostics tool so the default mode for
this option is deselected. Note that error and warning messages will always appear in your
status window regardless of this selection.

  

 Synchronize ports to symbol using node name

When this option is selected, the IFF import resets the symbol pin numbers to match port
numbers based on the node name of the schematic port. By default, symbol pin numbers
are matched to schematic port numbers based on the port's instance name.

 

 Use layouts from libraries instead of building local copies from IFF file

When this option is selected, library elements that already exist in the system libraries are
not recreated for the imported file. Instead, these elements are read from the local
libraries; if an element does not exist in a local library, then it is newly created. This
option is deselected as the default, and all elements are created/recreated in the local
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workspace.

 

 Default Library Name For Library Parts

When the IFF file does not specify a library name for a component that needs to be
created, the library name specified in this field is used. This is necessary for environments
that do not support the concept of a library.

Note
The Default Library Name For Library Parts field is identical to the field of the same name in the Export IFF
Options dialog box. Changes made to this field will modify the contents of the field in the Export IFF
Options dialog box.

 

 About Component Libraries

A component library in ADS consists of a collection of component definitions. Each
primitive component has an associated component name, symbol and predefined
component parameters that include relevant physical and electrical characteristics.

The IFF translator can be used as the initial step in creating an ADS component library
however, this topic is outside of the scope of this documentation. Creating an ADS
component library using IFF requires specialized tools and training. If you're interested in
learning more about this topic, contact Agilent EEsof-EDA's Solution Services.

 

 Trace Handling

Trace Handling enables you to select how you want your meander elements interpreted
during a translation.

Trace When this option is selected, meander elements are translated as simulatable
traces with pins. This is the default setting.
Path When this option is selected, meander elements are translated as primitive data
type with center line and width. The default for this option is deselected.
Polygon When this option is selected, meander elements are translated as polygons. The
default for this option is deselected.

Note
If you choose Use layouts from libraries instead of building local copies from IFF file in the Import IFF
Options dialog box, choose Path in the Trace Handling options. Fixed artwork is not simulatable, therefore
it is not necessary for the interconnects to be simulatable.

 

 Importing from a Schematic Window

If the import is invoked from the ADS Schematic window, the following Import IFF Options
dialog box appears.
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Note that the options for Importing from a Schematic window and from a layout window
are same except the Use layouts from libraries instead of building local copies from IFF file
check box and the Trace Handling options. For information on these options, refer to
Import IFF Options. Apart from this a new option Use port name for connected wire label
is added.

 Use port name for connected wire label

For each wire attached to a port, the wire label will be set to name of the port. To
maintain proper connectivity in the ADS environment, it is necessary to enable this option
if connectors share a common name.

   

 Exporting IFF Files 
To export an IFF file:

Follow the steps as outlined in Exporting a Layout (trans). For available options1.
(accessed via More Options in the Export dialog box), see Export IFF Options.
When the translation is complete, an Information Message window appears. Click OK2.
to dismiss this window.
The IFF Export log appears:3.
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Review the log, searching for any warnings or error messages generated during
export.
The log file appears in the Status window by default. This window is provided as a
means of viewing the file and is not intended for editing.
Click OK to dismiss this window.4.

  

 Export IFF Options 
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 Destination IFF File name

Use the Destination IFF File name field to enter the full path of the destination file.
Alternatively, you can click Browse to open the Export File Selection dialog box and
locate the destination path. After selecting the destination path and entering the file
name, click OK to accept the selection and return to the Export IFF Options dialog box.
The appropriate suffix is appended to the filename automatically.

  

 IFF File Overwrite Options

Overwrite IFF File When writing to an existing file, the contents of that file are
overwritten.
Append to IFF File When writing to an existing file, the new data is appended to the
existing file. This is the default setting.

 

 Output disabled instances to the IFF file
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When this option is selected, if an instance is disabled in the schematic, it will still be
output into the IFF file. If the checkbox is deselected (default), disabled instances will not
be exported. This option can be utilized to omit certain components from being transferred
to remote environments that might not support the components (e.g. disable the
simulation components prior to creating an IFF file to send to Cadence, which does not
have any definitions for the simulator components). Activate this option if you want to get
everything. Deactivate this option if you want to filter out the unused/unwanted
components.

 

 Output ADS Item Definition properties

When this option is selected, ADS Item Definition properties are utilized to recreate the
information necessary to simulate a component for ADS. For example, if you have
parameters on a resistor, some Item Definition properties are created in the IFF file (e.g.
R_ADS_UNIT=1), which allow the IFF importer to exactly recreate the component as it
exists in ADS. However, other tools will not recognize the Item Definition parameters, and
may misinterpret the properties as being separate. If library symbols are being exported
to other environments that do not recognize the ADS Item Definition parameters, the
option should be turned off. This option is deselected by default.

 

 Put a space between numbers and the scalar/unit

When this option is selected, parameter values are exported as they normally appear in
ADS (i.e. with a space between the number and the scalar, e.g. "1 pF"). If the checkbox is
deactivated, the exporter converts the values into the IFF value specification, which is to
have no space between a number and a scalar (e.g. "1pF"). Ideally, an IFF exporter
should interpret either form of number, and set the value internally to whatever is normal
for that environment. Some environments (e.g. Mentor Graphics) do not interpret the IFF
property values in any way. For Mentor IC, this means the numbers need to have no
space in them, because, when they are used within SPICE simulations, the space will
cause syntax errors in the simulator. However, for Mentor Board, they require the ADS
components to have a space in them, because the RF Architect ADS library is set up to
expect values to have a space between a number and a scalar/unit.

If you are exporting designs to Mentor Boardstation, you must select this option for IFF
imports to work into their environment. An additional issue can come up if you create
variables, and then assign scalar values to the variable (e.g. "R1 kOhms"). When this is
exported, if the option is not set, it would convert to "R1koh", which could no longer be
interpreted correctly. Note that this second option is considered bad practice (the scalar
should be included in the variable value for R1, and no units should be specified);
however, ADS does allow you to format variables in this way. If you are using variables in
this way, you must set this option to true. This option is deselected by default.

 

 Output annotation position for schematic components

This option stores information about the position of the component text annotation in the
schematic window. Annotation text includes the component type, name and parameters as
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displayed next to the component. Enabling this option may be useful if the annotation has
been moved in ADS, though even with this option enabled some environments may not
preserve the position of the annotation.

 

 Default Library Name For Library Parts

When the IFF file does not specify a library name for a component that needs to be
created, the library name specified in this field is used. This is necessary for environments
that do not support the concept of a library.

Note
The Default Library Name For Library Parts field is identical to the field of the same name in the Import
IFF Options dialog box. Changes made to this field will modify the contents of the field in the Import IFF
Options dialog box.

 

 About Component Libraries

A component library in ADS consists of a collection of component definitions. Each
primitive component has an associated component name, symbol and predefined
component parameters that include relevant physical and electrical characteristics.

The IFF translator can be used as the initial step in creating an ADS component library
however, this topic is outside of the scope of this documentation. Creating an ADS
component library using IFF requires specialized tools and training. If you're interested in
learning more about this topic, contact Agilent EEsof-EDA's Solution Services.

  

 Schematic Hierarchy Option

The Schematic Hierarchy Option drop-down list enables you to establish how much of the
schematic hierarchy is exported:

Current Design Only Write current level only. Complete design information for the
current design is exported. Instance-specific information (parameter values and
coordinates identifying position) is also exported. Detailed definitions of a referenced
design are not exported.
Current Design and All Library Parts Complete design information for the current
design is exported. Referenced designs that reside in a library selected for inclusion during
export and are part of the current design's hierarchy are also exported. In addition, library
parts are exported.

  

 Library

Displays the current library. If hierarchical, all included libraries are listed in the
appropriate order.
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 Libraries Included During Schematic Export

The libraries for which schematic design information is exported. You may customize this
list if the current library is hierarchical. (Note that complete layout hierarchy is always
exported.)
To add a library to this list:

In the Library list, click the desired library.1.
Click Include. The library is added to the Libraries Included list.2.

To include all Libraries, click Include All.

To remove a library from the Libraries Included list:

In the Libraries Included list, click the entry you want to remove.1.
Click Remove. The library is removed from the list.2.

To remove all entries from the Libraries Included list, click Remove All.
 



Advanced Design System 2011.01 - Importing and Exporting Designs

72

 IGES Translator
IGES (Initial Graphics Exchange Specification) is a neutral graphics database format
designed primarily for data exchange between mechanical CAD systems. The IGES file
format links mechanical CAD systems to Advanced Design System. Two-dimensional
geometry can be used to interchange layout or package outline information.

The Advanced Design System IGES translator can either create or read an IGES ASCII
form file. The basic input requirements for the translator are the file to be translated and
the configuration message file. The output is the translated file.

The IGES translator can be run via the layout window menu commands File > Import
and File > Export.

The IGES format can represent both mechanical and electrical design data in two and
three dimensions.

For IGES output, it is important to consider the limitations and capabilities of the intended
receiving system. IGES is a very general language. Many IGES translators understand only
a sub-set of IGES entities. If the receiving system is CALS Level 1 compliant, there should
be no problem. If it is not, before you begin layout carefully review the types of entities
the receiving system is able to accept and what options are available in the layout output
translator. The translator is extremely configurable, but may still be unable to output
every entity in a form acceptable to another system.

 

 Translator Description
 The Advanced Design System's IGES output is compatible with IGES versions 4.0 and
5.0. The output is CALS Level 1 compliant. However, because many IGES pre-processors
accept different types of IGES files, the translator is designed to be highly configurable
through the use of the Import and Export Options dialog boxes. For more information on
the options provided in these dialog boxes, see the sections Import IGES Options and
Export IGES Options later in this section.
  

 Importing IGES Files 
The procedure for importing each format is generally the same, however the available
options differ. For a step-by-step tutorial on importing a layout file, refer to Importing a
Layout (trans). For specific import options related to importing IGES Files, refer to Import
IGES Options.
 

 Import IGES Options

To explore Import IGES Options, in Layout window, click File > Import > IEGS > More
Options.
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 Precision  

This value should be the same as the precision with which the drawing file was created. A
warning is generated if the precision is less than the drawing file precision. Possible values
are 0, −1, −2, −3, −4, or −5. The default is −3.

  
 
  

 Exporting IGES Files 
The procedure for exporting each format is generally the same, however the available
options differ. For a step-by-step tutorial on exporting a layout file, refer to Exporting a
Layout (trans). For specific export options related to exporting IGES Files, refer to Export
IGES Options.

 

 Export IGES Options

To explore Export IGES Options, in Layout window, click File > Export > EGS > More
Options.
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 IGES Extension 

If you do not specify an output file name when exporting the file, the program takes the
input file name and appends this extension to create the output file name. The default
extension is igs , but any three character string can be used.

  

 Units

These are the units that the IGES file will be written in. You may select from the following
options: same, mil, inch, um, mm, cm. The default is same. When same is selected, the
design is written in the same units that are stored in the design file. For more information
on choosing layout units, refer to  Setting Units/Scale Factors (custom) in Customization
and Configuration (custom).

  

 Exponent Character

For case sensitive post processors, this option enables you to specify either upper-case (E)
or lower-case (e) exponents. The default is E, or upper-case.

 

 Author

Your name. This is written into the Global Section (the first three lines of the IGES file)
and is not required.

  

 

 Addnl. Scale Factor

 If this value is other than 1.0, the output coordinates are multiplied by that value. The
default is 1.0. You may enter any integer or double precision float number.

  

 Precision

This value should be the same as the precision with which the drawing file was created. A
warning is generated if the precision is less than the drawing file precision. Possible values
are 0, −1, −2, −3, −4, or −5. The default is −2.

 

 Organization
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Name of your company or organization. This is written into the Global Section (the first
three lines of the IGES file) and is not required.

  

 Create Top

When selected, this adds a Substructure Instance Entity to the IGES file at the top level of
hierarchy. Create Top is selected as the default.

  

 Include Fill

This is selected as the default. However, not all post-processors support fill patterns. To
eliminate fill patterns in filled polygons, deselect this item.

  

 Include Text

This is selected as the default. However, not all post-processors support text. When this
option is deselected, text is eliminated from the IGES file.

 

 Holes As Polygons

This is selected as the default. However, not all post-processors support holes in polygons.
When Holes As Polygons is deselected, polygons are written with false edges.

 

 Flatten

 When Flatten is selected, all levels of hierarchy are automatically removed and a single
flat design is translated. There will be no references from the top level structure to any
other structure. This option is useful when your post-processor does not support or
correctly translate hierarchy in IGES files. Please note: if a substructure was instanced
more than once, selecting this option increases the size of the file.
This option is deselected as the default.

  

 Reverse Arcs

When selected, the program writes all arc− as arc+ by interchanging the start and end
points. This forces polygons to be written as line segments. This option is deselected as
the default.
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 Conv Arc to Lines

When selected, the program translates an arc into of line segments. You should select this
option if your post-processor places random arcs on a drawing. This option is deselected
as the default.

  

 Polygons As Open Polylines

When selected, closed polygons are written as open contours. This retains arcs in outline
form. This option is deselected as the default.

   

 Polygons As Segments 

When selected, all copious data entities are changed to composite curve entities. Arcs are
retained in outline form. This is useful for post-processors that cannot read IGES solids.
However, when this option is selected, the size of the output f ile greatly increases
because each line segment is written on a separate line, and each coordinate that is a
vertex gets written twice. Also, knowledge of segments belonging to a polygon is not
retained.
This option is deselected as the default.

  

 Explicitly Define Defaults

If your post-processor complains because there are blanks in the Directory Entry Section
fields, or that the parameter and record delimiters are not specified, select this option.
Otherwise, Explicitly Define Defaults is deselected as the default.

  

 ZeroFillSequenceNumbers

If your post-processor complains because the sequence numbers do not have zero fill,
select this option. Otherwise, ZeroFillSequenceNumbers is deselected as the default.

  

 ZeroFillTerminateSection

If your post-processor complains because the terminate section has zero fill, deselect this
option. Otherwise, ZeroFillTerminateSection is selected as the default.

 

 Name Properties

When selected, all Name Properties are preserved and exported with the IGES file. By
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default, this option is deselected.

   

 Overcoming Limitations of Other IGES Readers 

IGES Reader Problem Advanced Design System Solution

  Can't read clockwise arcs Convert arcs to lines (Conv Arc to Lines)

  Can't read hierarchical IGES Flatten the design

 Can't read IGES solids Reverse arcs (polygons are converted to line sets)

 Can't read lower-case exponent Specify Exponent Character as E (or e)

 Text won't transfer Deselect Include Text

 Defaults not explicitly defined Select Explicitly Define Defaults

 Zero fill in termination section  Deselect ZeroFillTerminateSection

Zero fill not in se quential numbers Select ZeroFillSequenceNumbers
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 Mask Files
Created by Agilent EEsof EDA for use with its EDA tools, the mask format is a simple
ASCII format that provides a flat geometric representation of a layout. Because of its
simplicity, this format offers great flexibility when transferring designs between the
Advanced Design System and other design environments.

The Gerber and DXF translators use the mask file format as an intermediate file when
converting data to Gerber and DXF. The mask format is also used as an intermediate file
when translating other formats such as HPGL/2. In addition, the simplicity of the mask file
format makes it an appealing option for post-processing designs and extracting drill hole
file information (you will need to create your own programs for these tasks).

Mask files can include multiple layers of data, but this data describes geometric forms
exclusively. Simulation data, element parameters, substrate definitions, and hierarchy are
not included.

  

 Importing Mask Graphics Files 
For a step-by-step tutorial, see Importing a Layout (trans).

 

 Import MASK Options

The More Options dialog box allows you to specify the layers for the import of MASK
format files.

Layers

The Layers tab displays a list all the layers in a MASK file. Layers can be selectively
imported to ADS using the import column. By default all layers are imported.

If the unit mentioned in the import file is different form layout unit then a warning
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message (trans) is displayed.

   

 Exporting Mask Graphics Files 
For a step-by-step tutorial, see Exporting a Layout (trans).

 

 Export MASK Options

The More Options dialog box allows you to set the options for units, formats, and layers
for export.

More Options

 
  

 Options

The Options tab allows you to select Units, Hole Format and Attributes in the translation.

 Units

These are the units that the mask file will be written in. You may select from the following
options: mil, inch, um, mm, cm. The default is mil. For more information on choosing
layout units, refer to Setting Layout Options > Preferences for Layout > Setting
Units/Scale Factors in Customization and Configuration (custom). 

  

 Scale X, Scale Y

These are the fields for inputting the scale factors for shapes in the direction of X and Y.
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The default settings are 1.0, 1.0.

 Hole Format

The Hole format section enables you to define how the translator deals with holes in a
design.

 
Holes As Polygons

When Holes As Polygons is selected, holes are exported as a filled element, which is also
how polygons are exported in the mask format. When Holes As Polygons is not selected,
polygons with holes are translated as single-segment polygons, the false edge segment
becoming part of the polygon.

Note
Some systems may not be able to tolerate this type of complex polygon. For these systems, make certain
that Holes As Polygons is selected. This option is deselected as the default.

 
Holes As Cutlines

When Holes As Cutlines is selected, holes are converted into cutlines. This option is
selected as the default.

 
Preserve Holes

When Preserve Holes is selected, holes are exported as an empty element. This option is
not available for exporting mask graphics files.

 Attributes

  
Arcs As Polygons

When Arcs As Polygons is selected, the design arcs are exported as line segments (or
polygons). This option is deselected as the default.

 Layers

The Layers tab displays a list all the layers in a MASK file which can be selectively
exported to ADS using the export column.

Layers
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The Export column enables you to deselect one or more layers to exclude it from the
output file. Default setting is all layers are selected and exported.
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 MGC/PCB Files  
 MGC/PCB files are IFF files that are used exclusively for Mentor Graphics design transfers.
This format is available from the Advanced Design System layout menu only, yet it
enables the transfer of both schematic and layout information.

When you select the MGC/PCB export format from an Advanced Design System Layout
window, both a layout and schematic IFF file are exported in a single step. The design
data is exported into a standard directory tree contained in the program's workspace
directory structure.  The standard directory is called to_mgc.

The exported files are placed within this directory in a subdirectory that is named the
same as the design being exported. This subdirectory contains an information file and the
translated schematic and layout IFF files. Thus, if you were translating a design called test
, the exported files (design_info, schematic.iff and layout .iff) would found in a directory
called to_mgc/test.hpxfer.

From the Mentor Graphics Design Manager, a single command called  import_hpeesof
imports the schematic and layout data into Boardstation and Design Architect. This
command automates to a single procedure the steps required to transfer both the
schematic and the layout.

Mentor PCB products do not accept layout hierarchy, so the entire layout is flattened prior
to building the Mentor layout.
 

 Exporting MGC/PCB Files
This section outlines the procedure for translating designs into MGC/PCB format. For more
information on transferring designs between the Advanced Design System and the Mentor
Graphics Falcon Framework, contact your Agilent Technologies sales representative.

To export an MGC/PCB file:

Follow the steps as outlined in Exporting a Layout (trans). For available options1.
(accessed via More Options in the Export dialog box), see Export MGC/PCB Options.
If the option Prompt For User Message was selected, an Export MGC/PCB Options2.
message dialog appears:
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 Enter any messages to be included with the design transfer. This information is used
only by the import_hpeesof utility (see MGC/PCB Files) and is not kept with the
design.
If you do not wish to include a message in the file, you may leave this window
empty. If you want to print the message, click Print.
To proceed with the transfer, click OK.
When the translation is completed, the IFF Export status appears:3.

Review the log, searching for any warnings or error messages generated during
export.
This window is provided as a means of viewing the file and is not intended for editing.
Click OK to dismiss the Status window.4.
  

 Export MGC/PCB Options
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 IFF File Overwrite Options

 Overwrite IFF File
When writing to an existing file, the contents of that file are overwritten. This is the
default setting.
Append to IFF File
When writing to an existing file, the new data is appended to the existing file.

 

 Default Library Name For Library Parts

 The name of the library to which the library parts are written. Design objectives are
stored in a group that uses the same name as the workspace directory, but library parts
are stored in either the default library hpeesoflib or a library that you specify.

Note The default library name can contain only alphabetic and numeric characters.

 

 Output disabled instances to the IFF file

When this option is selected, if an instance is disabled in the schematic, it will still be
output into the IFF file. If the checkbox is deselected (default), disabled instances will not
be exported. This option can be utilized to omit certain components from being transferred
to remote environments that might not support the components (e.g. disable the
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simulation components prior to creating an IFF file to send to Cadence, which does not
have any definitions for the simulator components). Activate this option if you want to get
everything. Deactivate this option if you want to filter out the unused/unwanted
components.

 

 Output ADS Item Definition properties

When this option is selected, ADS Item Definition properties are utilized to recreate the
information necessary to simulate a component for ADS. For example, if you have
parameters on a resistor, some Item Definition properties are created in the IFF file (e.g.
R_ADS_UNIT=1), which allow the IFF importer to exactly recreate the component as it
exists in ADS. However, other tools will not recognize the Item Definition parameters, and
may misinterpret the properties as being separate. If library symbols are being exported
to other environments that do not recognize the ADS Item Definition parameters, the
option should be turned off. This option is deselected by default.

 

 Put a space between numbers and the scalar/unit

When this option is selected, parameter values are exported as they normally appear in
ADS (i.e. with a space between the number and the scalar, e.g. "1 pF"). If the checkbox is
deactivated, the exporter converts the values into the IFF value specification, which is to
have no space between a number and a scalar (e.g. "1pF"). Ideally, an IFF exporter
should interpret either form of number, and set the value internally to whatever is normal
for that environment. Some environments (e.g. Mentor Graphics) do not interpret the IFF
property values in any way. For Mentor IC, this means the numbers need to have no
space in them, because, when they are used within SPICE simulations, the space will
cause syntax errors in the simulator. However, for Mentor Board, they require the ADS
components to have a space in them, because the RF Architect ADS library is set up to
expect values to have a space between a number and a scalar/unit.

  

 Schematic Hierarchy Option

This establishes how much of the schematic hierarchy is exported:

Current Design Only Write current level only. Complete design information for the
current design is exported. Instance-specific information (parameter values and
coordinates identifying position) is also exported. Detailed definitions of a referenced
design are not exported.
Current Design and All Library Parts Complete design information for the current
design is exported. Referenced designs that reside in a library selected for inclusion
during export and are part of the current design's hierarchy are also exported. In
addition, library parts are exported.

   

 Library  



Advanced Design System 2011.01 - Importing and Exporting Designs

86

Displays the current library. If hierarchical, all included libraries are listed in the
appropriate order.

 

 Libraries Included During Schematic Export

 The libraries for which schematic design information is exported. You may customize this
list if the current library is hierarchical. (Note that complete layout hierarchy is always
exported.)
To add a library to this list:

In the Library list, click the desired library.

Click Include. The library is added to the Libraries Included list.1.
To include all Libraries, click Include All.2.

To remove a library from the Libraries Included list:

In the Libraries Included list, click the entry you want to remove.1.
Click Remove. The library is removed from the list.2.

To remove all entries from the Libraries Included list, click Remove All.

 

 Prompt For User Message

 When selected, a user message window appears before the transfer is initiated. This
window enables you to enter any messages that you want included in the translated file.
For more information about the user message, see Export MGC/PCB Options.

This option is selected as the default.



Advanced Design System 2011.01 - Importing and Exporting Designs

87

 ODB++ Translator
The ODB++ Artwork Translator translates artwork directly from circuit layouts created
with Advanced Design System into ODB++ format. Alternatively, ODB++ files can be
converted to ADS designs also.

 Importing ODB++ Files to ADS
To import ODB++ files:

From the layout window, choose File > Import. The Import dialog box opens.1.
Enter the Import file name and Layers file name in the appropriate fields.2.
Select either ODB++ Directory Format or ODB++ File Format from the File type3.
drop-down list.

To view and/or define import options, click More Options.4.
Set the desired options. For available options, see Import ODB++ Options.5.
Click OK to import ODB++ file into ADS.6.
If the unit mentioned in the import file is different form layout unit then a warning7.
message (trans) is displayed.
If the selected ODB++ file is too large, a Confirmation dialog box opens.8.

Select Yes. Layers dialog box opens. You can check or un-check layers. If you select9.
No, all layers are imported.
Click Cancel to stop import.10.
A Status window opens displaying the import information.11.

http://edocs.soco.agilent.com/download/attachments/115608692/odbImport1.JPG
http://edocs.soco.agilent.com/download/attachments/115608692/ImportConfirmation.JPG
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Note
Status Window displays warning occurred during ODB__ import. The layers on which drill is
applicable are also mentioned in status dialog. Additionally,the warning in status window is saved in
<Workspace Dir>/readodb.log

 

 Import ODB++ Options

The More Options dialog enables you to select layers and ODB Options to control the
import of ODB++ files. An ODB++ file and layers file must be selected in the main import
dialog for More Options dialog to open.

 ODB++ Options

By default Layer stack information is imported. To import only layers un-check the
Generate layer stack from ODB Options tab

 Layers



Advanced Design System 2011.01 - Importing and Exporting Designs

89

The Layers tab displays a list all the layers in ODB++ file. By default all layers are
imported. To import selective layers, un-check the layers from Import column under
Layers tab. Polarity and Type are non-editable fields and are displayed only for
information purpose.

 Limitations and Considerations

To import ODB++ data reliably in ADS, ensure that the ODB++ data is exported with1.
finer precision than the original design precision by increasing the layout precision
before doing export.
When you click More Options button and if the ODB++ file is too large, a warning is2.
displayed.

Text and other properties for components are not imported while importing the3.
component layer.
Only geometrical information will be imported. Net name and other net properties will4.
be ignored.

 Exporting ADS Design to ODB++ Files
ADS exports ADS layouts into a single compressed archive with the .tgz file extension. You
may specify the output path and file name, but the default is <Workspace
Dir>/mfg/<Design Name>/odb/<Design Name>.tgz. These translated files can be viewed

http://edocs.soco.agilent.com/download/attachments/115608692/LayersODBImport.gif
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with any third party viewer that supports ODB++ (e.g. Valor Universal Viewer from Valor,
AutoVue from Cimmetry, ViewMate from Pentalogix) to verify the exported design.

To export ODB++ files:

From the layout window containing your design, choose File > Export.1.
The Export dialog box opens.
In the File type drop-down list, select ODB++.2.

To view and/or define export options, click More Options.3.
Set the desired options.4.
For available options, see Export ODB++ Options.
Click OK to save your settings or Cancel to retain the default settings.5.
In the Destination Archive field, accept the default directory, or click Browse to6.
locate a new destination directory.
The archive directory is defined as <Workspace Dir>/mfg/<Design Name>/odb/
where:
<Workspace Dir> is the workspace directory
<Design Name> is directory named with the design name

Note
The check box option View file after export is not applicable for the ODB_+ file type.

Click OK to export the ADS layout design to an ODB++ archive.7.
If you attempt to write to a folder which is not empty and/or previously contains8.
ODB++ data, a confirmation dialog is displayed.
Choose Yes to overwrite with the current export data. Otherwise, choose No to9.
return to the Export dialog.

A Status window opens displaying the export information, if successful.
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If the export is unsuccessful due to out of range co-ordinates, an Error dialog is10.
displayed.

To save the log message, select text, copy, and then paste into any text editor.11.

 

 Export ODB++ Options

The More Options dialog enables you to set hole format, output units, path geometry,
export layers, and drill file definitions.
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 Options

 Hole format

In ADS, when a hole is created in a geometrical figure (like polygon), a cutline is
introduced. This is a false edge connecting the outer boundary of the polygon with the
inner boundary. This polygon is actually a single re-entrant polygon. When you select
Holes as cutlines, this re-entrant polygon is translated to ODB++ as-is. The default is
Holes as cutlines.

 Holes as cutlines

Select Holes as polygons to remove the false edge from the polygon.

 Holes as polygons

Select Holes as polygons to export holes as filled elements. The polygon will appear to
have no holes when this option is selected.

 Unit

Available units are inch or mm. Inch is the default.

 Line width for polylines

Polylines in ADS have zero width. Use this option to provide a width for drawing this
polyline in the ODB++ format.

If the export of polylines and arcs (both zero width entities) is not required, then set the
width to zero.

 Layers

All the layers used in the design are displayed on the Layers tab. By default, all layers are
displayed and selected for export. You can avoid exporting a specific layer by deselecting
the checkbox in the Export column for that layer.
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 Drill

Drill files are configured from the Drill tab. While exporting a layout design in ODB++
format, layers names containing drill features are appended with _drl. Only the selected
drill features for that layer are exported.

Select the check box to designate the drill layer to export. When a layer is selected, all the
tools on that layer are automatically selected. By default, no drill layer is selected.
Tool Dia. (Diameter) is an editable field. By default the Tool Diameter value equals the
Drawing Diameter value. If Tool Diameter is set to 0.0, the Tool Diameter will be equal to
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the Drawing Diameter in the output drill file.

 Limitations and Considerations

Note
The tool only exports the geometrical data. No netlist data, layer stack, or component data is exported.

Designs beyond the (x,y) co-ordinates of (-100, -100) and (100, 100) will not be
exported and an error message will be issued. Ensure that your design follows this
limit.

It is recommended to create the ADS design using inch or mm as the unit and set the
appropriate resolution.
If a layer does not have any via (circles), then it will not be displayed in the Drill tab
and no drill file will be generated for that layer.
One drill file will be generated for each layer having at least one drill feature.
Drill files will be created and packaged in the Destination archive selected in the
Export dialog.
Drill layer name is the same as the ADS layer name with extension _drl appended to
it. For example, drill file for the layer cond will be cond_drl.
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